tomate-gtk-aur-package/PKGBUILD

34 lines
916 B
Bash

pkgname=tomate-gtk
pkgver=0.25.0
pkgrel=1
pkgdesc="A timer for the Pomodoro Technique"
arch=("any")
url="https://github.com/eliostvs/tomate-gtk"
license=("GPL")
depends=("desktop-file-utils"
"gnome-icon-theme"
"gtk-update-icon-cache"
"gtk3"
"hicolor-icon-theme"
"playerctl"
"python"
"python-blinker"
"python-dbus"
"python-gobject"
"python-pyxdg"
"python-venusian"
"python-wiring"
"python-wrapt"
"python-yapsy")
makedepends=("python-setuptools")
options=(!emptydirs)
source=("https://github.com/eliostvs/$pkgname/archive/$pkgver.tar.gz")
md5sums=('8ade6ca500e3776fc226700b207fa785')
install=tomate-gtk.install
package() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
}